NOR2 Layout Example with labels
Below is the schematic that we will be creating a layout for.  As part of this exercise will learn how to merge sources and drains.

· We will merge the source and drain of the two PMOS transistors to minimize parasitics and area (transistor chaining).  

· For the NMOS we will merge the two drains of the NMOS transistors.

First create the schematic of the NOR2 shown
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1) We begin by creating a layout view of this cell.  From the Library Manager select:  File->New->CellView
· You will see the menu below

· Enter the information shown

· Be sure to enter layout as the View Name
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The two windows shown below are for layout.  The LSW window contains the layers that you will use to draw the transistors.  The other window will contain your actual layout 
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In layout, drawing takes place on an x-y coordinate system in units of microns.  At the top of the window you can tell the x-y position of your curser at any time.  When you perform move and stretch commands the amount that you move/stretch is shown as dx, dy, also on the top window.  All parts and polygons must snap to a lambda/2 grid or they will be in error.  For the ami06 process this is .15 microns since lambda is .3 microns.

2) The system defaults to not showing drawing layers.  This needs to be changed to change this.  From the top toolbar of the schematic composer select: Options->Display
· You will see the pop-up display menu shown below

· Change the number of Display Levels to 10

· Hit Save To
· Hit OK to close the window
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As with schematic entry there are useful bindkeys most are the same for schematic entry:

Bindkeys  (again most are the same as for the schematic editor)

 i
add instance

 q
edit properties (can be used to rotate)

 m
move

 s
stretch (maintains connectivity)

 c
copy

 r
create a rectangle (not rotate!)

 w
add a wire

z
zoom in

 Z
zoom out

 f
fit to screen

f6
redraw

u
undo last command

delete
delete

esc
end command

The NMOS and PMOS transistors do not need to be drawn individually.  Instead we can use Pcells which are part of the design kit.  

3) To place an NMOS transistor:

· Hit bindkey i (add instance) 

· Hit Browse
· You will see the pop-up menu below

· Select:

· Library:  NCSU_TechLib_ami06
· Cell:  nmos
· View:  Layout
· Hit Close to close the window
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4) Hit Hide to close the add instance window

5) With your left mouse click on the location in the layout window where you would like to place the part

6) Hit <esc> to stop adding parts

Note at this time the nmos part is just a single transistor.  We need to have two and they should be in parallel.  To reduce capacitance and area we will merge the drains of the two transistors
7) In the layout window, select the nmos part (This is the same procedure as for the schematic)
8) Hit bindkey q (edit properties)
9) You will see the menu shown below

10) To adjust the length and width go to Parameter.  The default length and width are fine for this example 

11) In this example we are also going to use the multiplier field to merge the two drains.
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Note:  the NMOS transistor shown has three connections to metal.  The contacts are already in place.

To place a PMOS trasnsitor:

12) Hit bindkey i (add instance) 

13) Hit Browse 
14) From the NCSU_TechLib_ami06 Library get an pmos pcell, View layout
15) Place the part on the schematic.  Note at this time it is not correctly sized.

16) In the layout window select the pmos part

17) Hit bindkey q (edit properties)
18) As with the NMOS the length and width can be adjusted by going to Parameter
19) Change the width to be 3um
20) Change the number of fingers to be 2
Fingers are used to place transistors in series.  The “fingers” are the polysilicon gates.  Here we have two.  

21) Place the PMOS transistors on the layout above the NMOS transistors.  Note the PMOS transistors are already in a awell.
Note it is not possible to make a connection to the merged source and drain as it is with multiplier. There is no contact.
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Note:  the PMOS transistor shown has two connections 
to metal.  The contacts are already in place.
For this example we will rotate both the NMOS and the PMOS parts.

22) To rotate an instance in layout:

· Select the NMOS transistors
· Hit bindkey q (edit property)

· You will see the pop-up menu shown below

· Select Attribute 
· Select the type of rotation (In this case 90 degrees)
23) Rotate the PMOS transistors 90 degrees as well
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24) Running DRC

Before proceeding so you might want to run a DRC (Design rule Check) to ensure that your layout is not violating any design rules

To run a DRC from the top toolbar in the layout window choose:  Verify->DRC.  
· You will see the menu below.  

· Hit OK to the run the DRC and close the window
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Errors are highlighted in the layout.  For this example we deliberately have an error.  The n-well of the PMOS is too close to the active of the NMOS
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More specific error messages also appear in the CIW (icfb) window and give reference to the number of the design rule error. (see below)
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We shall now move on to connect the devices.  We will do this by drawing polygons.  There are two ways to draw polygons with paths and with rectangles.  We will learn both.
To draw either a path or a rectangle you first need to define your drawing layer.  This is done in the LSW window.  
25) Left click on the drawing layer in the LSW window. In this example we have selected poly.
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26) Creating a path

One way to draw a polygon is with a path.  This is sometimes used for wires.  In our example we will create a path in poly to connect the gates of the transistors.  A rectangle, which we will describe shortly, could also be used.  

· Make sure poly is selected as a drawing layer

· To create a path hit bindkey p (sometimes unreliable) or use the create path icon on the left hand side toolbar (shown below)

· Following this, the menu shown below will appear.

· Set the width of the path to .6um.  This sets the width of the path.  (Note also that the drawing layer is specified as poly)

· Hit hide to close the menu
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· Below is a diagram illustrating how a path is drawn.  On your layout single click with your left mouse at to define starting point of your path (take your finger off the mouse button!!!!!).  

· Move your cursor to where you would like there to be a bend. (keep your finger off the mouse button!!!!!).  single click with your left mouse to indicate the position of the bend.

· Repeat the previous step to add additional bends.
· Double click with your left mouse to terminate the path (see following page)

When you draw polygons it is sometimes preferable to overlap existing polygons as is shown below
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Finished Path…
27) Connect the other two gates to each other
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In addition to connecting the parts you need to add substrate and well contacts for the NMOS and PMOS transistors.

28) Creating a substrate contact for an NMOS:
The substrate connection to the NMOS is p+.   As with the transistors, this can be automatically created.  The resulting part is: p+ connected to a contact connected to metal 1.

· Hit bindkey o (create contact)
· You will see the pop-up menu shown below (on the left)

· For contact type select M1_P (this stands for connecting metal1 to p+)

· Hit hide to close the pop-up window and place the contact
· Hit <esc> to stop placing contacts

· Place the substrate contacts on either side of the NMOS transistors (see below)
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29) Creating a well contact “tap” for a PMOS:
The well connection for a PMOS transistor needs to be in the same well as the transistor itself.  The design kit allows well contacts to also be automatically created.  The part that is formed is:  Nwell, n+, metal 1 and a contact

· Hit bindkey o (create contact)
· You will see the pop-up menu shown below (left)

· For contact type select NTAP (this stands for n-well tap)

· For improved connection change the number of rows to three

· Hit hide to close the window and place the contact

· Hit <esc> to stop placing contacts 
· Place the part on one side of the PMOS transistors (see below)

· Important:  the contact should be touching the well that the PMOS transistors are in
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At this point you should have something like this
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We still have some connections to make, for these we will use rectangles however we could have used paths.
30) In the LSW window select metal 1 as the drawing layer

31) Hit bindkey r to create a rectangle (more reliable: use the create rectangle  icon on the lhs of the window- see below)

32) With your left mouse single click to indicate the first corner of the rectangle as shown below (do not drag the mouse!)

33) Again with your left mouse single click at the corner diagonally opposite to the first to complete the rectangle

34) Draw the three rectangles shown below.

Variation:
· In drawing the rectangle you can first zoom in and click on the first coordinate of the rectangle and then (in the middle of the create rectangle command) use multiple zoom , pan, and/or fit commands to gain a better vantage for placement of the second rectangle coordinate.  This technique can be used with other drawing commands as well. 
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After you have created this rectangle or any other polygon.  You can edit the rectangle (and other layout parts) by hitting bindkey q (edit properties).  For a rectangle you can change the coordinates and the drawing layer.  Remember coordinates must be a multiple of half lambda.
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We will next use vias and contacts to make connection to the inverter

35) To place contacts and vias 

· To place a contact or via hit binkey o 
· You will see the pop-up menu below.  There are different kinds of connections that can be made.  Below is a table summary

· We will connect metal 1 to poly with a contact.  To do this select M1_Poly
· We use two contacts arranged in two columns for lower resistance and improved reliability.  You should use multiple contacts/vias whenever you can. 
· Below is the layout with the M1_Poly contact





	
	Connects

	M1_P
	Metal 1
	P+

	M1_N
	Metal 1
	N+

	M1_POLY
	Metal 1
	Poly

	M1_ELEC
	Metal 1
	Poly2

	M2_M1
	Metal 2
	Metal 1

	M3_M2
	Metal 3
	Metal 2

	NTAP
	Forms an n-well contact
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Next we are going to add two on top of the sources for the two NMOS transistors

· Hit bindkey o, and select M2_M1 as a Contact Type
· To connect the two ground together place a rectangle of metal 2 as shown below

· Also connect the drains of the two transistors to form the output using metal 1 (see below)
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At this point you should check and save your work
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On the pages following are other commands that are helpful.  Practice them

Rulers
Sometimes it is helpful to place rulers on the page as shown below.  

· A ruler can be placed using: the ruler icon on the lhs of the screen, hitting bindkey k, or using Window->Create Ruler
· Click once to start the ruler and a second time to end it

· Use K or (Window->Clear all Rulers) to remove rulers
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Deleting

To delete a portion of layout first select it:

· Click on it with left mouse button or draw a selection box keeping the left mouse button pushed down

· Then hit the delete key
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Copying

· Hit c ( for copy) or Edit->Copy
· Select what you wish to copy

· Click your cursor at the destination location

· Hit esc to end the command

Variations:  you can rotate or flip the object while you copy it
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Moving:

· Hit m ( for copy) or Edit->Move
· Select what you wish to move

· Click your cursor at the destination location

· Hit esc to end the command

Variations:  you can rotate or flip the object while you move it

You can restrict the snap mode of the move command
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Stretching

Stretching, a variation on moving, can be a useful command.  In the diagram below the metal 1 needs to extend further up.

· Hit s ( for stretch) or Edit->Stretch
· Draw a selection box which incorporates an edge to move.  Below is a selected edge.

· Click on the selected edge and drag to new position. 

Varitations:
· Stretching is a very powerful command.  You can select large sections of completed layout and in this way move the sections of layout to a new position while preserving connectivity.  This can be helpful in making room for other circuitry.  
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Adding pins
· From the top toolbar select:  Create->pin
· Enter the names of the pins on the schematic

· For easier reading under Display Pin Name Option change the font to roman
· Change the pin width to .3

· The Pin type should agree with the layer that the pin is on (see below)
[image: image33.png]Create Symb

1ol
Hido | canco welp|

Terminal Names |3 B vdd gnd ¥
CKeepFrsthiame  pion [0 vion [0

Mode ® sympin - auto pin - shape pin

W Display Pin Name Display Pin Name Option...

10 Type * input output - inputOutput
switch . jumper

Pin Type metalt

Pinviatn [0 Pin Length |0

Access Direction M Top I Bottom M Left Ml Right
W Any | None





[image: image34.png]



Single click left mouse to create bend
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Double click to end





Click once with left mouse





Click on opposing corner to end
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Click your cursor on the destination location





Click your cursor on the destination location
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With Fingers there is no connection to metal 1





With multiplier there is a connection to metal 1





Type of rotation
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The PMOS transistors are already in a well
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Touching!





x-y coordinates define placement and size or rectangle.  They are the coordinates of the two points used to create the rectangle. 


Numbers must be multiples of .15um





The drawing layer can be changed





Connect with metal 1 rectangles
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Add M2_M1 contacts (vias) here





Connect drains using metal 1– this is the output





Metal 2 connects ground





Create path icon





Create rectangle icon

















A pin placed here would have a pin type of metal1





Check and save





The x-y position of your cursor in microns





A pin placed here would have a pin type of poly
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