MATHCAD TUTORIAL
The Fundamentals

Notice

This manuscript contains the tutorial on using Mathcad 7 Professional version as taken from the software built-in
tutorial. Very minor editorial work has been done to present the material in a instruction form to fit the needs of the
course Dynamic System | taught by the Department of Mechanical Engineering at FAMU-FSU College of Engineering
which uses MathCad very intensively. Production of this manuscript if sorely for interna purposes and should not be
used in any other form without permission from the owners of the work , MathSoft Inc.

Mathcad is a unique, powerful way to work with equations, numbers, text, and graphs. Unlike any other math software,
Mathcad does math the same way you do. That's because it looks and works like a scratchpad and pencil. Mathcad's
on-screen interface is a blank worksheet on which you can enter equations, graph data or functions, and annotate with
text -- anywhere on the page. And instead of forcing you to use a programming-like syntax, Mathcad lets you use the
language of mathematics.

In a programming language, for example, equations look like this:
X=(-B+SQRT (B**2-4* A*C))/(2*A)
In a spreadsheet, equations go into cells looking something like this:
+(-B1+SQRT(B1*B1-4*A1*C1))/(2*Al)

In Mathcad, the same equation looks the way you would see it in atext or areference book:

-b + Jbz -4-.ac
X=

2-a

The only difference is that Mathcad's equations and graphs are live. Change any data, variable, or equation, and
Mathcad recalculates the math and redraws the graphs -- instantly. With Mathcad, you can solve a wide range of
technical problems -- from the simple to the very complex -- numerically or symbolically. You can also visualize
equations and datawith 2D and 3D graphing. With Mathcad Electronic Books you also get a wealth of mathematical
knowledge and reference material -- al live and ready to be dragged and dropped into your worksheets. Most
important, Mathcad gives you all the power you need to get the job done -- from start to finish. With Mathcad you can
truly do it al -- explore problems, formulate ideas, analyze data, model and test scenarios, select the best solution . . .
then document, present, and communicate the results. Using Mathcad’s connections to the Worldwide Web, you can
also share your Mathcad worksheets with colleagues and other professionals. This means you can collaborate easily
during any phase of aproject -- and you can do it in the rich and powerful language of mathematics.




A Quick Tour of Mathcad’s Features

In Mathcad, you can . . .

1. Do arithmetic with Mathcad'’s built-in functions and math operators

The operator palettes accessible from the paette strip at the top of the window give you access to Mathcad’s
mathematical operators. First click in your worksheet to place a red crosshair cursor, then click on a button in one of
these palettes to insert a math operator into your worksheet. To see ascrolling list of Mathcad's built-in functions, go to
the Insert menu and select Function, or click on the Insert Function button on the toolbar.

+

The red crosshair

]

Insert Function button

Here are afew examples. These calculations are computed internally to 15 places, but you can show fewer placesin the
answer -- just click on an answer and choose Number from the Format menu, then change the number in the
Displayed Precision field in the dialog box.

Get the square root and the power from the Arithmetic Palette, and type = to see the answer. For the four basic

operations, use+, -, *, and/ right fromthe keyboard.
1.837-10°
= 2.3142353232
100 + 3°

The standard engineering and math functions are built in.
log (1347.2 ) -sin <%n> = 2976

Mathcad’s functions and operators handle complex numbers. . .

(23 + 47 )% + €377 = 148613 - 47.498i
... and units. To see the built-in units, choose Unit from the I nsert menu, or click on the appropriate toolbar button.
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Insert Unit button
2. Define your own variables and functions
The definition symbol :=isin the Arithmetic Palette; you can also enter it by typing acolon (: ).

a-=4



a+J;:6

When you change a definition, Mathcad immediately recal culates any new values that depend on it.

f(x) = sin (x)

a
f(10) = -0.218
Try it! Click just to the right of the 4 in the definition of a above so you see the blue editing lines:

a::ﬂ

Then type [Backspace] once to get a placeholder:

a::j

Now type 3. Click the mouse anywhere else on the screen and you'll
see the answers change.

3. Evaluate functions and expressions over ranges

The .. range operator is in the Arithmetic Palette and can also be entered by typing a semicolon [ ; ] at the keyboard.
Change the 2 in the definition of Z to a 4 to see bigger tables. To create these tables, just typez=, f (z) = and so on.

Z:= 0, 5.2

z

al

0
0.5]
1
15
2

f(2)

o

3.835
3.366
2.66
1.819

exp(f(2)) z
0
23.156
28.959
21.444
12.326




4. Plot functions quickly

Usethe X-Y Plot button in the Graph Palette, or type [Ctrl]2 to get a plot operator; then type expressions you want to
plot in the middle placeholders on the x and y axes. You can type expressions on the y axis only, and Mathcad will
choose a default range for you automatically on the x axis! Y ou can enter several expressions separated by acomma(, )

in these axes placeholders to see multiple traces.

4
f(x)
sin(x)
0
—2
-10 0 10

5 Visualize data in two and three dimensions

The following plots show how Mathcad can automatically interpolate a 3D scatter plot to create a surface plot. The
same array of pointsis displayed in both plots. Thefirst plot was created using Graph/3D Scatter Plot from the Insert
menu, and the second plot was created using Graph/Surface Plot from the Insert menu. Y ou can also use the
corresponding buttons from the Graph Palette.




X,Y,Z
6. Compute sums and integrals

The sum and integral operators are in the Calculus Palette. To build one of these expressions, click in your worksheet
to position the red crosshair, click on the appropriate button in the palette, then fill in each placeholder.

10
Z il = 27182818
n!
n=0
vy
dx = 0.785
1+ X2
0

7. Do matrix computations

To enter amatrix, click on the 3 by 3 matrix icon in the Vector and Matrix Palette (or choose Matrix from the Insert
menu), choose the number of rows and columns, then fill in the placeholders.

45 1

A=|5 0-12

-72 8
To compute the inverse, just type AM- 1=.
0.074-0.117-0.184
Al=]0135 012 0163
0.031-0.132-0.077

To find the determinant, type avertical bar, | , or use the button on the Vector and Matrix Palette.

|A| =326



8. Solve equations numerically

Start Mathcad's root finder off with aguess. . .
t=1

... and Mathcad finds the closest root.
root (12 - cosh (1) ,t) = 1.621

9. Carry out symbolic operations
By factoring x' -1 yields (x - 1) -<x6 e xt e e xZ e xs 1>

00

2 .
and eX dx Yidds iﬁ
2
0
The quadratic expression
1
X+ 1=—
X
has solution(s)
i + i 5
2 2
-1 1
—— - _.J]5
2 2 J—

You perform these symbolic operations by clicking on an expression and choosing commands from the Symbolics
menu. You'l find commands for simplifying, expanding, factoring, differentiating, integrating, solving an equation,
generating series expansions, carrying out symbolic matrix operations, and more. Copy the expression below to your
main worksheet window, then click on it so you see it surrounded by blue editing lines (if necessary press the spacebar
to select more of the expression); then choose Simplify from the Symbolics menu:

10. Create multiline procedures using new programming operators

Use the operators on the Programming Palette in Mathcad Professiona to build multiline Mathcad procedures with
standard control structures. for and while loops, branching, recursion, and more. Programs are seamlessly integrated
with Mathcad’s live worksheets and math notation and can operate on scalars, vectors, arrays, and even arrays of arrays.
Look at the following programming example.

f(x) = .Jl(x)-cos<—FR'A‘NIE '2'T[>
20

a:=20

b .= 3.833

xn = 17

m:= 25

i=0.xn

j=0.rm

NthRoot (a,n,¢) := | estrt e%

n

while |estrt " a| >¢

a

estrt %<1 - i>-estrt +
n 1

n-estrt "

estrt



The above program implements Newton's method for finding nth roots of numbers within a tolerance e which is then
used in the following example.

;= a+ 1
Xn
210
SS. = —T +
J m
Xc, | = rryesin <$j>
Y | = rri-cos<ssj>

Zc, ;= f(rri>-sin <$j>
NthRoot (7,5,107%) = 1.476

11. Create animationsto visualize results over time

Any part of a Mathcad worksheet can be animated. Try animating the graph below by choosing Animate from the
View menu, then entering values of FRAME from 0 to 20 in the dialog. Next drag-select the regions below including
the graph and equations to the right, and finally press Animate. Y ou will see the animation pre-process. Then you can
Mathcad lets you play back and save the animation as a standard video file or embed it in your worksheet.

Xc,Yc,Zc

This only scratches the surface of Mathcad's mathematical features, but we hope it whets your appetite to explore the
product further! In the next sections you'll learn how to create the basic elements of Mathcad worksheets: eguations,

text, and graphics.
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Lesson 1. Mathcad Tool Barsand Palettes

Features of the Mathcad Window

Before you move on to learning more about Mathcad's features and especially about building math and text in your
own Mathcad worksheets, take a moment to look at the Mathcad application window in front of you.

.
TheMain Menu

File Edit “iews Inzet Format Math Sembolice Window  Help

Here is your gateway to math, graphics, and symbolic functions and provides commands that handle the details of
editing and managing your worksheets. Click on the Math and the Symbolics menus to see the array of computational
functionality available to you in this product.

Accessto any M athcad Electronic Books you may have installed is now avail able through the Help menu.
L
The Math Palette

22| A 18] 23] 8| =

Below the main menu is atear-away bar whose buttons bring up palettes of math operators. If you let your mouse hover
over each of the buttons on the bar in turn, you'll see atool tip telling you what palette each button brings up:

Arithmetic Palette

%

Calculus Palette

|¢z
Evaluation and Boolean Palette
()

A
Programming Palette

g
[

Graph Palette

-
Symbolic Keyword Palette

Vector and Matrix Palette
oefi
Greek Symbol Palette

Click on one of these buttons in the bar to bring up the associated operator palette. You can then use the operator
palettes to insert math symbols right into your Mathcad worksheet.
e TheTool Bar

N SRy & =ale] @t | &el= &2A 82

is another tear-away button bar that provides shortcuts for many common tasks, from worksheet opening and file
saving to spell checking to bringing up lists of built-in functions and units. Depending on what you're doing in your




worksheet, one or more of these buttons may appear grayed out. Tool tips will remind you of the functions of each of
the buttons. One useful buttonis:

&

Launches the Resource Center, that contains QuickSheets, template Mathcad worksheets that solve many common
math tasks, from graphing to data analysis as well as extensive reference tables, and other useful information.
e  TheFormat Bar

Mormal j ITimesNewHDman j |'|2 j B | I | g| Ig %lg”
This is where you can format your text and math at the click of a button. If the Format Bar is not showing, select

Format Bar from the View Menu.
¢ TheResource Center Navigational Controls

Al R ESI N e =
appear whenever you have a Mathcad Electronic Book open and give you ways to browse among the sections of the
Book and find topics of interest. This Tutorial you are reading is in fact a Mathcad Electronic Book! Just let your
mouse hover over each of the navigational buttons at the top of this window to see atool tip explaining what each one
does.
e Findly, the messageline

« 1
Insering text in text region. type Shif-Enter to exit. | auto |

at the bottom of the Mathcad window gives you status alerts, tips, keyboard shortcuts, and other helpful information. It
also lists the calculation status of your worksheet -- "auto” here means that the worksheet is in automatic mode, which
means Mathcad will automatically recalculate any math expressions if you make edits to your worksheet. You can tell
when Mathcad is recalculating because "WAIT" appears on the message line and the cursor changes to a flashing
lightbulb. Other information that appears on the message line is whether you have the Caps Lock or Num Lock key
depressed on your keyboard, as well as the page number of the current worksheet.

Step-by-Step Editing Guide
A mathematical expression in Mathcad is a remarkable object: It is both a picture on your screen (or on paper when
you print out a worksheet) and a set of instructions for computing something. Mathcad’s equation editor is thus a
unique blend of word processor and code generator, an efficient way of building expressions that look right and
calculate correctly. The next lessons focus on teaching you the basics of entering, building, and editing math
expressions, with afew detours to talk about text and graphics in Mathcad worksheets. These are orgainsed as follows

Working with M athcad Regions

Entering Math and Text

Working with M athcad Styles and Templates

Defining Variables

Defining Functions

Building M athematical Expressions

Editing Expressions

Defining Range Variables

Defining Vectorsand M atrices

Creating Graphs

Formatting M ath and Text

Formatting Results

Using Units




Every Mathcad equation, text paragraph, and plot in aworksheet is a separate object called aregion. You can select a
single region by clicking in math or text in your worksheet. The region then shows up with athin rectangle around it. If
you move your cursor to one of the edges of the region, notice how your cursor changes to a small hand -- which lets
you move the region. Try dragging the regions below to your worksheet window. Note that if you click in the math
region, you will see blue selecting lines under the materia currently selected. If you click in atext region, you will see
black boxes at each corner and the middle of each line. These boxes allow you to resize text regions, which you can do
in your worksheet window, but not in the Resource Center.

A mathregion X := 100 A textregion The assignment above was created by typing x: 100

Moving Regions
You can aso drag-select multiple regions at one time to move them around on the screen to your liking. To move

regionsin your worksheet:

e Click in an empty areato position the red crosshair cursor in your worksheet and then drag-select regions so they
appear in dashed selection boxes.

*  Moveyour cursor inside one of the boxes. Notice that it becomes a small black hand.

e Hold down your mouse button and drag your mouse. All of the selected regions will move with it.

Once you have the regions positioned the way you want them, release the mouse button and click on an empty part of
the screen to deselect the regions.

Hint: If you want to grab a group of regions, but want to deselect one of them, use shift click on individua regions, to
do so.

Another way to see the regions in your worksheet is to choose Regions from the View menu. The region boundaries
will be highlighted against a contrasting background. An important property of Mathcad is that it reads your document

from left to right and top to bottom, just as you read a book. For an example of what this means, select the y2 =100
below and drag it above the definition of y (the definition of the variable is done in Mathcad with the colon-equals
symbol; more on that later). You will see that Mathcad is no longer able to tell you what y 2 equals because it doesn't

know what Y equals yet. Notice that if you drag the region below the original assignment, it computes!

y = 10

y% = 100

You can also easily delete selected regions. Select the math regions above in dashed line boxes and choose Cut from
the Edit menu. (Y ou may need to copy the regions to a worksheet of your own to try this out.) Now click in the empty
space above and choose Paste from the Edit menu to reinstate the equations. Y ou can see how this can be useful if you
delete something by accident. Using this technique, you can select many regions at once and clear them away. And, if
you make a mistake, you can easily bring the regions back, provided you bring them back before you Cut something
else
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Lesson 3: Entering Math and Text

Entering M ath
Click your mouse in the blank space below so you see ared crosshair cursor. Now type:

Type1l+ Seeon screen

1+j

After you type the + you see a little black box delimited by blue editing lines. In Mathcad this black box is caled a
placeholder. If you continue typing, whatever you type next will appear in the placeholder. For example, type 2 in the
placeholder, then press the equals key (=) to see the resullt.

If you click outside the region, or press [Enter], you should see:

1+2=3

The basic operators are listed below, along with their keystrokes and Arithmetic Palette button equivalents. To see the
Arithmetic Palette, click on the Math Palette button.

=]

Math Palette button

Operation Keystroke Button Example
]

Addition + 2 +2 =4
=

Subtraction - ' 2-2:-0
&

Multiplication * 2.2 =4

=

Division / E =1
2

Powers n 22 .4

Notice that math in a Mathcad worksheet appears in familiar math notation -- multiplication as a raised dot, division
with afraction bar, exponentsin araised position, and so on.

Entering Text
To create atext region, click in ablank area of the screen to position the red crosshair cursor and type a double-quote

["]. You can dso just start typing, and as soon as you type a space, Mathcad converts from a math region to a text
region. Typing certain characters used in math will not automatically convert to a text region, so it is always safest to
use the double-quotes.Now you can now type whatever you like, just as in a word processor. Notice that as the text
region grows, a black box appears around it, and there are resizing "handles’ on the right and bottom edges of the
rectangle. Once you are done, click outside the text region to go back to inputting math. The black selection box
disappears when you're no longer working in the text region.
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L esson 4: Working with Mathcad Stylesand Templates

Introduction

Two new features in Mathcad 7 are styles and templates, which work much like those in word processors. We have
provided severa templates for your use or revision, each containing a number of styles. You can also create your own
styles and store them in atemplate so they are available for other documents.

Using a Template
To use a built-in template, choose File/New, then choose a template from the templates listed, or browse to your own

template directory. Just substitute your own text or bitmaps in any of the placeholders, or use or revise the built-in
styles.

Using Styles
The styles in each template are visible from the first pull- down menu in the Format Bar. If the Format Bar is not

visible, choose View Format Bar. Styles save you work, because you can quickly apply a style such as Heading One
to specific text regions, instead of having to redefine the font, size, and indents for each new heading. To create or
modify astyle, choose Format Style. To save your stylesfor usein new files, you must make atemplatefile.

Creating a Template

Creating a new template or revising another template is very easy. Y ou can

*  createtext styles and number formats

» st thefonts and sizesfor constants and variables in math regions

* add any bitmaps that you want on every page such as aline across the top or bottom of the file

e put page numbers, filenames, and the current date in headers or footers

e set theformats for numbers

Then Save As and choose under File of Type, Template. Make sure to have the file extension be .mct. Y our settings,
styles, and bitmaps will be available for the next file you create, saving you the time of redoing that work for each file.
Thiswill also help make your files more consistent.
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L esson 5: Defining Variables

Often you will want to define a number as a name you can use in subsequent calculations. For example, click to
position the red crosshair in an empty space below and type:

Type age: 23 See on screen

age = 23

Notice that when you type the colon [:] key or, press the assignment operator key

on the Arithmetic Palette, Mathcad displays :=. The assignment operator (“colon equals') in Mathcad is used for
definitions. To see what age equals, you just type the name followed by the equals sign:

Type age=



If you wanted to assign a different value to age, just click to the right of the 23 on the right-hand side of the definition

of age above, backspace over it to delete it, and enter the new value. Notice that as soon as you press [Enter], age=
changes as well. Because of this ability to vary the value of a name, this type of definition is called a variable in
Mathcad. You can now use a Mathcad variable in an equation:

age = 23

age 10 = 230
Or, use the variable to define another variable:

old := age -10

od = 230
Try defining some variables of your own (you can call your variables X or MONEY_SPEN or any other names you
can think of) and use them in equationsin your main worksheet. Remember that you use the assignment operator [:] for
definitions, and you type [=] to calculate an answer.

The syntax used for defining a function in Mathcad is the same as you see in textbooks. For example, position the red
crosshair in ablank areaand try typing:

Typef(x):x*2 Seeon screen

flx) = 22

Notice that you use the assignment operator to define functions, just as you use the assignment operator to define
variablesin Mathcad. Once you've defined afunction likef ( x) , you can useit in a number of ways:

f(x) = x?

... Pluginanumerical value as the argument of f( x) .
f(10) = 100

... Define avariable and plug it in as the argument of f( x) .
X =3
f(x) =9

... Define arange variable (more on thislater) and plug it in as the argument of f( x) to seeatable of vaues.
a:=0.3

f(a)

.. . Even define another function in terms of f( x) .

a(y) = f(y) +6
g(x) = 15

Y ou can define a function using expressions you build up from the keyboard or from the palettes of math operators, as
described above, and you can aso include any of Mathcad’s hundreds of built-in functions. To see a scrolling list of
built-in functions along with brief descriptions, select Function from the Insert menu, or click on the



button on the toolbar. The Insert Function dialog box, pictured below, lets you insert a function name directly into a
math placeholder in your worksheet.

Inzert Function

Function

Ok

acosh(z]
anale(s, v]
APPENDfile) EEE
APPEMDPRMIfile]
arglz) LI Cancel

)

Dezcription

The angle [in radianz] whoze cozine iz 2. Principal value for
comples 2.

You can aso type the name of any built-in function directly from the keyboard. Here are just a few examples that use
some of Mathcad's built-in functions.

Trigand L ogs
In(26) = 3.258

csc (45 -deg) = 142
Matrix Functions

100
identity(3) = | 0 1 0
001

cols (identity (6)) = 6

Click to position the red crosshair in the empty space below and type the following. Pay particular attention to what
happens when you press the spacebar:

Type f(x):x+6[Spacebar]* (x" 3[Spacebar]-1) Seeon screen

£x) = (x4 6)- (= 1)




Thefirst time you pressed [Spacebar], you selected
x+ 6

in blue editing lines. So, when you typed the multiplication sign, you were multiplying this entire expression by the
expression that followed. If you hadn't pressed [Spacebar] the first time, you would have seen

K+6'X3—1

which is a completely different expression. When you pressed [Spacebar] the second time, x3 was selected in the blue

editing lines. Therefore, when you typed -1, you were performing subtraction on the entire expression X3. Compare
what you typed above to what happens when you type f(x): x+6* (x* 3-1) you probably get something that looks like

fiz) =x2+6 (XE_ 1)

The exponent operator is caled a sticky operator because your keystrokes will "stick" to the exponent until you
specifically ask to get out by pressing [Spacebar]. This stickiness applies to exponents, square roots, subscripts, and
division. To create the expression type bel ow:

2
¥ o+ 3

5

follow the following steps:

Type x"2[Spacebar]
Now X2 is selected in blue editing lines, then Type +3[Spacebar] so that the entire equation is in the editing lines,
then Type/ 5[Enter] and done!

If you try entering the expression again without pressing [Spacebar] after typing +3 you should get

7 3

X +—

5

And if try typing x* 1/ t ~2[Spacebar][Spacebar][Spacebar]/ 3 Y ou should get

You may need to create some of your own eguations in your main worksheet window in order to get a better feel for
sticky operators.




Understanding the structure of expressions in Mathcad will help you edit them efficiently. Looking at the highlighted
equation below, do the following with the mouse:

O

f(x) = X—— -x

*  Click on the sguare root symbol. Notice that the square root and everything under it is selected in blue editing
lines.

e Click immediately to the right of the 5 under the radical, then start pressing [Spacebar]. Notice how more and
more of the expression is selected in blue editing lines.

»  Click immediately to the left of the 3 in the exponent of x3, then start pressing [ Spacebar]. Notice how more and
more of the expression is selected in blue editing lines.

The blue editing lines define a subexpression that will be operated on by the next operator or expression you type. If
your editing lines are positioned to the |eft of an expression, the next operator or expression you type will appear to the
left of the vertical line; if your editing lines are to the right of an expression, the next thing you type will appear to the
right of the vertical line.

Now notice what happens when you use other mouse selection methods on parts of the highlighted equation below:

v

f(x) = — X

»  Double-click onthex intheexpression f( x) . Notice that double-clicking selects the variable in reverse video.

e Click to the left of the X2 under the radical, then start dragging your mouse to the right. Notice how more and
more of the expression is selected in reverse video.

When you select a part of amath expression in reverse video, the next operator or expression you type will replace the
selected expression. Thisis probably how you're already used to editing text on the screen in most word processors.
Try It Out!

f(x) = X5 s

- X
8
e If youwant to replace the 5 with a6, double-click on the 5 so it appears in reverse video, then type 6.
« If you want to replace the division with multiplication, click to the left of the 8 in the denominator, press the
[Backspace] key, and type [*].
e |If you want to take the square root of the entire right side of the equation, click to the left of the radical and press
[Spacebar] until the entire right-hand side is selected in blue editing lines. Then type abackslash [\]s.

 If you want to subtract i .x instead of x3 on the right-hand side, drag-select the x2 and then type
2
1/ 2[Spacebar]* x.
If you are editing an expression and make a mistake, just select Undo from the Edit menu to return to the original
expression. Or, if you recently saved your worksheet, close it without saving changes and reopen it.

Here is another example you can try to get the hang of editing math in Mathcad. Enter the following lines in the
MathCad editor



X := 15

2.x% + ;x +2- 875

then edit the last expression so that it looks like

-2.(x - 5)2 +;x - 2= 2275

The variable x has been defined at the beginning so you can see the effects of your edits.

Here Arethe Steps. . .

e  Firgt, changethe x° to (x - 5) 2 Double-click on thefirst x in the expression and then type x-5.

*  Now change the leading constant from 2 to -2. Click immediately to the left of the leading 2 so you see blue
editing lines, and then type - .

e Now edit the fraction E . Double-click on the 3 in the fraction bar to select it and then type 5.

2

*  Finaly, change the addition at the end to a subtraction. Click immediately to the left of the final equals sign in the

expression so you see blue editing lines. Press [Backspace] to delete the plus sign. Now type [-].

So, incorporating everything you've learned so far, try to reproduce
the following equations yourself:

score = 3
A/score +6 + E
2
result =
score 2_ 3
result = 0.583
Y ou should have typed

score: 3[ Enter]

resul t:score+6[ Spacebar]\ +1/ 2[ Spacebar ]
[ Spacebar]/score”2[ Spacebar] - 3[ Enter]
resul t=[ Enter]

If you had trouble with this, try practicing with some more examples until you feel comfortable editing Mathcad
expressions.
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L esson 9: Defining Range Variables

Assigning arange of vauesto avariable is straightforward in Mathcad. For example, to create a variable X that runs
from O to 10, just click to position the red crosshair in some free space and type x: 0; 10

After clicking away, you should see

®:=0.10

Notice that when you type the semicolon character [;], it displays on the screen as two dots (..) followed by a
placeholder. This is Mathcad’s range variable operator. Another way to put the range variable operator in your



worksheet is with the Range Variable button

-]

on the M ath Palette.
You can now use a range variable as you would any other variable. Notice that Mathcad creates an output table -- a

vertical series of boxes that contain numbers -- when you type[=] after an expression involving arange variable.
Xx:=0.5

f(x) = -2-(x-5)2+ g-x -2

Type x= See on screen

La[s[w[n][r[o] >

Typef (x) = Seeon screen

f(x)
-52
-315
-15
-25
6
105

If you want your range to be in increments other than 1 (the default), enter the next value in the range after the first
one. For example, to create arange variable X that goesfrom 1 to 10 in increments of 0.1, type:

Typex:1,1.1;10 See on screen

z:=1,1.1.10

Notice that you typed a comma before the second value in the range, and then you typed the semicolon [;] after the
second value. Here are some other examples, along with the keystrokes used to create them:

Typex:1,1.1;1. 8 Seeon screen
Xx:=1,11 . 18

Type data: -10, -8; 0 Seeon screen
data = -10,-8. 0

Type n: 202, 192; 102 Seeon screen
n:= 202,192 . 102

Here the range goes down!



Type x= Seeon screen

X

1
11
12
13
14
15
16
17
18

Type dat a= Seeon screen

data
-10
-8
-6
-4
-2
0

Type n= Seeon screen

n

202
192
182
172
162
152
142
132
122
112
102

Try defining your own range variable and using it in an expression below.
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L esson 10: Defining Vectorsand Matrices

The examples you've seen so far have involved single numbers or scalars. Mathcad has many powerful features and
functions, however, for dealing with arrays of numbers, such as vectors and matrices. Creating a vector or matrix in
Mathcad involves just choosing the dimensions of the array and filling in the placeholders. For example, to create a

vector V like the one shown below, click to position the red crosshair in some free space and
e  Typev:
e Choose Matrix fromthe Insert menu (or click on the matrix button inside the Vector and Matrix Palette)

«  Fill in the appropriate number of rows and columns. For example, the vector below has 3 rowsand 1 column.

e Click onInsert.

*  Fill in the placeholders with the appropriate values. Use [Tab] to move from placeholder to placeholder inside the
vector, or click on the appropriate placeholder to select it.

3.3

vi=|[-12

8

To access a particular element of a vector, you use the subscript operator, which you create by typing a left square
bracket ([ ), or by using the

button in the Arithmetic Palette. By default the first element has the index O:

Type v[0= See on screen

Vo: 3.3

The next element hastheindex 1:

Typev[1= Seeon screen
v, = 12

The last element has the index 2, and so on:

TypeVv[2= See on screen
v, =8
For convenience, you can define the index as arange variable to access all of the elements at once:

Typei:0;2 Seeon screen
i:=0.2

Then

Type v[i= Seeon screen

Vi

33
-12
8
For your exercise, try defining avector and itsindex. It's important to understand that an index for a vector will aways

be a range of consecutive integers in Mathcad, starting from 0. Any values not specifically defined by you will be
defined to equal 0 by Mathcad. For example, consider the followings:




Typei:2;5 Seeon screen
i=2.5
Typewrong][i:1 See on screen

wrong, = 1
Typewrong= See on screen

0]

0
1
wrong -
1
1

1

Y ou might expect the vector wrong to have four elements (the 2nd, 3rd, 4th and 5th). However, as you can seg, it has
six. This is because internally, Mathcad still keeps track of the Oth and 1st elements. And because these were not

specifically defined, Mathcad made them equal to O.

It is useful to use vector elements as arguments of functions. For example, we'll use the constants and function defined
below:
b: 97

a=11

fv) = 3y

2
9-b
Now define avector and use its elements as an argument of the function:
33

vi=|-1.2

+ a

111
1.098
1131

Try defining a vector and using its elements in a function. You can also use vectors as arguments of functions. For
example:

Typef(x):[Ctrl]4x See on screen
f(X) = X
Here we use the vector summation operator, which is also available viathe

El

button on the Vector and Matrix Palette.
3.3

v=|[-12
| 8

f(v) = 10.1



Most of the vector and matrix operators can be found in the Vector and Matrix Palette, but here is alisting of a few
basics:

Operation Keystroke Palette Button  Display
Hey
Dot product [Shift]8 V'W (Displays like scalar multiplication).
Hx¥
Crossproduct [Ctrl]8 V x W
||
Determinant | M|
H{}
Column [Crl]6 M 2 (Returns the 2" column of M)

Mathcad has a wide variety of built-in functions for manipulating vectors and matrices. Here is a small sampling,
using the matrix M defined below:

7 9 1
M=|6 -8 2
5 7 3
Purpose Example
Number of columns cols (M) = 3
Number of rows rows(M) = 3
Largest value in matrix max(M) = 9

11.526
eigenvals (M) = |-11.463
1.938

Eigenvalues of amatrix




Mathcad makes it easy for you to create an x-y plot. Just click in a new file, type an expression that depends on one
variable, for example, sin(x), and then click on the X-Y Plot button

in the Graph Palette, or choose X-Y Plot from the I nsert/Graph menu. Then press[Enter]. Voila, aplot! You should
see anicely formatted plot that looks like this:

.0.999982, T
05+
sin(x) | : : |
-1 -5 0 5 10
5
~0.999982, 1
- 10, X A0,

Try It Out!

The expression you plot doesn't even have to be a function of X. Try typing y” 2[spacebar]-3*y, followed by the @ key
(a shortcut for creating an x-y plot). Mathcad will plot over a reasonable default range for the dependent variable in
your expression. Here are a couple of other expressions you can try plotting in this way:

1. z-cos(z)

2. 1

1+X2

Graphing a Function Using Range Variables
When you graphed the above expressions, Mathcad was choosing a default range for the dependent variable. You can
have control over the range of values that are plotted. To graph a simple function using a range variable, do the
following:
»  Defineafunction of one variable that you wish to plot. For example, graph the following function: Typef (x) : -
x"2[ Spacebar] +8*x- 27 Seeon screen
f(x) := -x% + 8x - 27
«  Define an independent variable for the horizontal axis. For example: Type x:0;10 See on screen
x:=0.10
*  Createyour plot by clicking in the worksheet window, then type @ to create the x-y plot and type x in the middle
placeholder on the horizonta axis and type f(x) in the middle placeholder on the vertical axis. Then press[Enter].

Y our plot should look like this:



_20 -

f(x) 30T

_40 -

_50 £

X
Those of you familiar with the plot of f(x) will notice that the trace looks a little rough. To smooth the trace out, try
changing the definition of X highlighted aboveto X := 0, 0.1 .. 10. The smaller increment (or step) means more

points calculated, which means more plotted, which makes the trace smoother because Mathcad is ssimply connecting
the dots.

To format an x-y plot, just double-click on it (or choose Graph from the Format menu) to bring up aformatting dialog
box. The tabbed dialog box lets you change options for logarithmic axes, grid lines, legends, trace types, markers,
colors, axis limits, and more. Experiment with the x-y plot below. Double-clicking on any Mathcad plot -- contour,
surface, polar, vector, etc. -- brings up an appropriate formatting dial og box.

x:=0,01. 10

-10

_20 -

f(x) 30T

_40 -

_50 £

Graphing Vector Elements
Here is a vector of data points called money_spent. We created the vector using the Matrix command on the Insert
menu; our vector below has 8 rows and 1 column.




0 OO W N

mon ent =
ey_sp 1

12.5
14
17

To plot these data points, the horizonial axis must be either (a) an index variable into the variable money_spe or (b)
another vector with the same number of elements. For case (), first define an index into the vector:

Typei : 0; 7 Seeon screen
i=0.7
Create your plot by typing [@] and typing

Typenoney_spent [i Seeon screen

money_spent

in the placeholder on they axis, and i in the placeholder on the x axis. Y ou should see a plot similar to this:

17, 2071
jul
’!
157
L
g
2
money_spenti 10 + -
e e o
dd
ST 'J‘
d-E‘
3!
2. : : : !
0 2 4 & 8
0 1 A

Notice here that box symbols have been used LoFl adashed blue line.

To demonstrate case (b), plotting two vectors of equal size against each other, we will define a second vector, called

day:

da.y =




o o W N

mon ent =
ey_sp 1

12.5
14

17
Now it's easy: Create the plot by typing @, as above, and type

Typenoney_spent Seeon screen
money_spent

in the placeholder on they axis, and

Typeday Seeon screen
day

in the placeholder on the x axis.

The resulting plot should look similar to this:

20T
(¢]
15T
(¢]
o
(¢]
10 T
(¢]
(¢]
5 -
o
(¢]

0 5 10 15

Here the "points' trace type has been used with magenta O’s. Notice that grid lines have been turned off on both axes.

Graphing a Function of Vector Elements

You can plot a function over a domain that doesn't contain evenly spaced points. For example, your domain could
consist of avector of values. Plotting a function of vector elements entails defining a function, defining a vector which
will be the domain for the function, and plotting. An example of thisis:

Define afunction of one variable.

Typef (x) : x*2 Seeon screen
f(x) = x2
Define a vector of numbers to be the domain for the function. Type x: followed by [CtrI]M , and fill in the Matrices

dialog box with the appropriate number of rows and columns (here, 5 rows and 1 column), followed by OK. Then fill
in the placeholdersin the vector.



-22

X = | 3.56
9.9
13

Define an index variable. Typei:0;4 See on screen
i=0.4

Type @ and fill in the middle placeholders on the y and x axes with f<x > and X;- The result should look similar to

i
this:

200 T
150 T
f<Xi> 100+

50T

-5 0 5 10 15

Here, the difference with plotting a function of a range variable is that the horizontal axis does not have to be in even
increments (such as 1, 2, 3, ..., 10). Rather, it can be any set of numbers you may wish to plot.

Graphing Two or More Functions
Plotting multiple functions over a single domain on a single graph is straightforward. For example, suppose you want

1
to plot both — and z2 on one plot. It's easy! Just type the two expressions separated by a comma and then type @:
z

Type Uz [Spacebar] ,z*2 @ [Enter] You'll seeagraph similar to this:



107

_10 A

z,z
In this example both expressions are plotted over the same default range of values, but you could use two separate
range variablesif you wish. Try it out in your worksheet window now.

Typef(x):sin(x) See on screen
f(x) = sin(x)

Typeg(t):t* 3 See on screen
3

g(t) =t
Type x:-10,-9.9;10 See on screen

x:=-10,-99. 10
Typet:-2,-1.9;2 See on screen

ti=-2,-19 .2
Then,
*  Type @ in some blank space.
e Inthe middle placeholder on the horizontal axis, type x,t.

* Inthemiddle placeholder on the vertical axis, type f(x),g(t).
e Type[Enter].

Y our result should look like this:



9 P LN : 4
a(t) —10\/ -5 0 \b/ 10

_10 4

X, t
Asyou can seg, plotting more than one function is simple --- just separate your arguments with acomma(,). The same
syntax holds for plotting multiple traces using vectors and functions of vectors.
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L esson 12: Formatting Math and Text
You can easily modify the way text and math appear in your worksheet. You can select different default fonts, sizes,
and styles using the controls on the Format Bar that appears in the Mathcad window. (If the Format Bar is hidden, and
you want to see it, make sure Format Bar on the View menu is checked.) If you're used to working with a word
processor, this should be familiar.
Definitions for plot:

x:=1,11 .10
For example, suppose you want to make the following style changes to the math and text in your worksheet.

f(x) = -2-(x - 5)% + ;-x -2
* Inthetext region, make the word "Here" appear in Courier 12-point bold.
e Change the math fonts to Times New Roman 12-point bold italic.

Hereis agraph of f(x).

20

f(x)

0 5 10



To practice, create some regions in your worksheet window by dragging them over. The directions to make these
changes follow.

Formatting Text
Here are the steps for changing the font and size for selected text:

»  Drag-select or double-click the word "Here" in the text region above when you are in your worksheet window.
The selected word will appear in reverse video.

*  Now choose your fonts and point sizes from the drop-down lists in the Format Bar, and click on the appropriate
buttons for specia effects like boldface, italic, etc.

Further text formatting options are available by choosing Text from the Format menu.

Text Stylesand Templates

You can access current text styles from the first drop-down list in the Format Bar. To make a new text style, choose
Style from the Format menu. If you want to save your styles to use in new documents, save thisfile as atemplate. You
can then open the template and all your styles will be available for new documents. Y ou may want to examine the built-
in styles and templates which you can see when you choose File New or in the Template directory.

Formatting Math
To change the math fonts, first notice that Mathcad distinguishes between variables (names of variables and functions

in math regions) and constants (humbers), and it lets you apply different font tags to each. Just click on a variable or
congtant in a math region and use the Format Bar or choose Equation from the Format menu to make any changes
you want for variables and constants.

Mathcad aso lets you highlight equations to emphasize them. Just click on an equation and choose
Properties/Highlight Region from the Format menu in the main worksheet window. To select different default colors
for the worksheet background and equation highlighting, choose Color from the For mat menu.

Now that you've learned how to get results, both numerical and graphical, there are a few tips you should know for
formatting your results in Mathcad. Suppose you define some function using the following steps:

Define the variables as constants
Type P:500 See on screen
P := 5000

Typer:.07 See on screen
r = .07

Typen:365 See on screen

n := 365
Define A asafunction of t, i.e. A(t)
TypeA(t):P*(1+r/n)"n*t See on screen

r n-t
A(t) = P-<l +_>
n

Get the results for different values of t
Type A(3)= See on screen

A(3) = 6.168 -10

3

This is a compound-interest calculation. Notice that by default Mathcad displays the result (highlighted above) in
exponentia form if it's larger in absolute value than 1000, and the result is shown by default with three places after the
decimal point. Suppose your calculation involved currency and you wanted to see the result in nonexponential form
with two places after the decimal point. To change the format of the result:



«  Double-click on the result (A(3)=), or click on the result and choose Number from the Format menu.
*  Noticethat the Number Format dialog box pops up.
e Change Exponential Threshold from 3 to 6 (or another value > 3).
e Change Displayed Precision from 3to 2.
e Clickon OK.
A (3) would now display as
A(3) = 6168.27

This changes the exponential threshold locally -- i.e., only for A (3). If you want to change it for the entire
worksheet,

*  Click on ablank part of the worksheet.

e Select Number from the Format menu.

e Change Exponential Threshold to the desired number.
e Change Displayed Precision to the desired number.
 ClickonOK.

Under Number Format, you can aso control, among other characteristics:
e Complex tolerance
e Zerotolerance

e Theradix of the result (octal, hexadecimal, or decimal) for integer values.

Plots, too, are easy to format via a dialog box you can summon by double-clicking on a result (plot), or by choosing
Graph from the For mat menu.

Suppose you want to change the traces on the following plot:

Typef(x):sin(x) See on screen
f(x) = sin(x)

Type g(y):cos(y) See on screen
g(y) = cos (y)

Typex:-10,-9.9;10 See on screen
X :=-10,-99 . 10

Typey:-2,-1.9;2 See on screen
y:=-2,-19.2

f(x)
a(y) —'1 —'5 0 \ '5 io

Xy



To create the plot above:

Type @ in some blank space.

In the placeholder on the horizontal axis, typex,y .

In the placeholder on the vertical axis, type f(x),g(y).

Type[Enter]. Notice that the traces are different colors. To reformat the plot,

Double-click near the center of the plot to see the X-Y Plot Format box. You can also access this dialog box in
your main worksheet window by clicking on a plot and choosing Graph/X-Y Plot Format in the For mat menu.
Click on the Tracestab.

Click ontrace 1, and change the Color to green (for example).

Click on trace 2 and change the Line to dadot (for example).

Click on OK.

Experiment with the different options to see how you can alter the trace types and other graph characteristics. For
example, you could end up with thisplot . . .

...orwith...

-2 -1 0 1 2

You can also make your plot log scaled (if appropriate), put in grid lines, set markers for emphasizing certain areas of
the graph, create legends and axis labels, even create atitle for the plot. Be sure also to try clicking once on a plot when
you are in the main worksheet window and then select Trace or Zoom from the Graph Palette. And, of course, you
can stretch the plot to make it wider or longer by dragging the sizing handles you see at the right and bottom edges
when you click on aplot in the main worksheet window.




One of the handy features of Mathcad is its ability to track standard units during calculations and to convert the units of
calculated quantities automatically. For example, you can define a variable in terms of the built-in unit kilometers
simply by multiplying anumber by km. Here we define the radius of the Earth and a surface area function:

Typer: 6370* kmSee on screen

r := 6370 -km
TypeA(r):4*p[Ctrl]g*r”2 Seeon screen
A(r) = 4-mr?

(The symbol Tlis also available on both the Arithmetic Palette and the Greek Symbols Palette.)
Then you can eval uate these expressions directly, or perform more extensive cal culations involving them:

TypeA(r) = Seeon screen

A(r) =500 .10 .m?
Notice that the result is automatically shown in terms of the base units of your default unit system -- in this case SI. To
see what the surface area of earth equals in hectares, click once on any part of the equation below and notice the
trailing black box on the right-hand side. Double-click on this black box to bring up thelnsert Unit dialog box. Then

double-click on one of the displayed units to replace the units shown.

4-tr? =500 104 .m?

Theresult in hectaresis

41r? = 5.000.1010 .hectare
This principle holds for all of the Mathcad built-in units, which is avery extensive list, as well as for any units you may
wish to define yourself. To seethelist of built-in unitsin Mathcad, choose Unit from the I nsert menu.

w := 100 -joule

w =100 -m -N

pm = 10°%m
smoot := 5.23 -ft

smoot = 1.594 -106 oim

um = 6273 -10 ' .smoot

The units feature is also very convenient because it lets you know if you have made a mistake in the units in your
calculations. For example, the force cal culation below should end up in newtons (or an equivalent force unit) . . .

a= 10
sec
mass := 2-kg
F := mass -a
F = 20 -s -newton

... but it appears to have an extraneous factor of second. Looking closely at the statements in the calculation, you can

see that the definition of the acceleration A is missing aterm of sec 1.
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Whereto Get MoreHelp

Congratulations -- you've learned the basics of working with math in Mathcad and know about producing text and
graphs, too! Enjoy the rest of your explorations.

Further help isavailable right in Mathcad in avariety of forms:

e ToolTips

¢ QuickSheets

« On-lineHep

¢«  Context-Sensitive Help
 MathSoft World Wide Web Site
¢« Other Resources

Each of these functions is described in more detail below.

ToolTips
Let your mouse pointer hover over a palette or toolbar button for afew seconds, and you'll see an explanatory tool tip

displayed near the button:

|
0|45 &
LIRS

3D Scatter Plot

Look also on the message line at the bottom of the Mathcad application window for helpful tips and shortcuts.

Resour ce Center and QuickSheets

To help you get going fast and keep you going beyond the basics found in the tutorial, Mathcad comes complete with
QuickSheets. QuickSheets provide mathematical shortcuts for frequently used analyses -- from graphing a function to
solving simultaneous equations to the analysis of variance. There are more than 300 QuickSheets in al. To open the
QuickSheets section, choose QuickSheets from the opening page of the Resource Center. Worksheets relevant to this
the course Dynamics Systems | at FAMU-FSU College of Engineering, Mechanica Department, are also reproduced
and attached with this manuscript in the Appendix.

On-lineHelp
2
Familiar on-line Help provides detailed, step-by-step instructions for using all of Mathcad’s features, mathematical and

nonmathematical. Press [F1] at any time, or choose Help Topics from the Help menu, or click on the Help button on
the toolbar.

Context-Sensitive Help

A useful context-sensitive Help feature can link you to the full Mathcad Help system from within your Mathcad
worksheet. If you're not sure about searching for the topic you're interested in, just click on error messages, operators,
and functionsright in your Mathcad worksheet and press [Shift][F1] to display the relevant Help screen.

MathSoft World Wide Web Site

If you have access to the Internet, you can link directly to MathSoft’s World Wide Web Site for Mathcad files,
technical support information, and more. You may use your usual Web browser (e.g., Netscape Navigator, Microsoft
Internet Explorer, Mosaic, etc.) to visit the MathSoft Home Page at http: //mwww.mathsoft.cony.

M athSoft Collaboratory
You can access the Collaboratory on the MathSoft internet site through the File Menu. Use these forums to post




guestions and problem files for other users who may have similar interests.

Other Resources

The popular Electronic Book, The Mathcad Treasury, by Paul R. Lorczak, provides a hands-on guided tour through
the mathematical features of Mathcad. Two chapters from this book are included in the Resource Center. Any
mathematical background needed to understand how each feature works is discussed, and then the underlying
algorithm behind the feature is presented. Furthermore, a wealth of tips, techniques, and working examples are
provided to help Mathcad users work more effectively with Mathcad. For more information about this and other
Mathcad Electronic Books, contact your local sales representative or reseller, or contact the MathSoft Sales
Department: phone 1-800-MATHCAD, e-mail sales-info@mathsoft.com.




